読者です 読者をやめる 読者になる 読者になる

かんがるーさんの日記

最近自分が興味をもったものを調べた時の手順等を書いています。今は Spring Boot をいじっています。

Spring Framework は 4.1.6 で 8u40 に正式対応?

3/25に Spring Framework 4.1.6 がリリースされたらしいので、以下のページを見ていたのですが、

Spring Framework 4.1.6 released
https://spring.io/blog/2015/03/25/spring-framework-4-1-6-released

Spring Framework 4.1.6 is also the first release to be formally compatible with the recently released JDK 8 update 40.」という記述がありました。 Spring Loaded が正常に動作しないので 8u40 にバージョンアップしていないのですが、Spring Boot で使用する Spring Framework のバージョンが 4.1.6 になるまで 8u40 にするのは止めた方がよいのでしょうか?

Spring Boot の GitHub を見ると、次の 1.2.3 で 4.1.6 に対応するようです。

https://github.com/spring-projects/spring-boot/issues?q=milestone%3A1.2.3+is%3Aclosed

Spring Loaded も GitHub を見たら 1.2.3 がリリースされていました。jcenter の方はまだ 1.2.1 なんですよね。。。 build.gradle に http://repo.spring.io/repo/ を設定すれば 1.2.3 が取得できると思われるので、Spring Boot の 1.2.3 がリリースされたら、Spring Loaded 1.2.3 をここから取得するよう設定して試してみましょう。

https://github.com/spring-projects/spring-boot/issues?q=milestone%3A1.2.3+is%3Aclosed